Support for Xcode 15 and iOS 17

  • 20 September 2023
  • 18 replies

Hey guys,


Is the SDK supposed to work on Xcode 15 and iOS 17? I’m getting the following error messages when trying to build my project after I upgraded Xcode:


FullStory: [2023-09-19 19:09:52:932] FullStoryCommandLine(23765:203821) Unable to locate the CoreSimulator directory. If you've recently installed or upgraded Xcode, make sure you've launched an app in the simulator at least once.


FullStory: [2023-09-19 19:09:52:932] FullStoryCommandLine(23765:203821) Failed to extract CUIAssets using simulator.

Best regards,


Best answer by megan 22 September 2023, 00:48

View original

18 replies

I am seeing the same issue when building my React Native app with Xcode 15.

Will there be a new FullStory React Native plugin that supports Xcode 15 / iOS 17?

I need to release my iOS app to the App Store!

@KeithC I had to remove Fullstory from my project for now until it has support.

@MarcVit-Superb Thanks! That is our last option. Did you try the most current FS plugin version of 1.41.0?

@KeithC I have tried the latest version of the native SDK, but was still getting the same error messages.


In the release notes they don’t list iOS 17, and state that Xcode 15 Beta is not supported:


@MarcVit-Superb I was told that 1.42.0 will hopefully be released tomorrow (Thu Sep20) that will have support for Xcode 15 (iOS 17).

Userlevel 5

Hi everyone! Closing the loop here to share that we’ve officially added support for Xcode 15 and iOS 17 SDK in today’s mobile release. Our release notes should be updated shortly. If you have any questions, let us know! And as always, is available for any technical troubleshooting. 

Thank you, Megan. I’ll give it a go, and will let you guys know in case I have any issues.


Thanks for the fix

Version 1.42.0 fixes it for me.

is there any change this patch can be upgrade to the react-native project? @megan 

Userlevel 5

Hey @ryanpliske! This release provides support for mobile app pages for React Native. Does that answer your question? If not, mind sharing some additional details on what you’d like to accomplish? Thanks! 

@megan no i don’t believe so.

i am looking specifically for a react native upgrade, not a native ios SDK upgrade.

I read through the FS docs and it doesn’t say anything I can find:

the one thing i did do was i manually updated the podfile to this
pod 'FullStory', :http => ''

and i got it working that way, but there’s no official documentation around the RN itself.

Userlevel 5

Hi @ryanpliske! Ah, I see. You're right; updating the SDK via the Podfile and modifying the React Native version in the package.json are distinct processes. It seems you've successfully managed to update the FullStory iOS SDK through adjustments in the Podfile. To upgrade the React Native module, you would indeed need to modify the version listed in your project's package.json file under dependencies.

We usually recommend using '^' in the version number. This way, it gets upgraded automatically with every build. However, we acknowledge that our documentation does not explicitly detail the process for upgrading the React Native module. Thank you for your patience and feedback here–it is much appreciated!

@megan i could be incorrect, but the react native package does not utilize the correct version of the ios sdk.

look at this:

i think your code utilizes the version from this json file.

I think you need to update this number and redeploy a new version of the react native package.

Userlevel 5

Hi @ryanpliske! I checked in with our mobile engineers here, and they offered a few points of clarification:

  1. The version in the linked json file is solely for testing and does not dictate the installed version of the FullStory SDK.
  2. The versioning of fullstory-react-native operates independently from the SDK's versioning. We ensure that fullstory-react-native maintains compatibility with both previous and subsequent versions of the native SDK. Consequently, upgrading fullstory-react-native doesn’t affect the support for iOS 17 or Xcode 15.

I’m not an expert on iOS, but it looks like the latest native SDK published on cocoapods is version 1.33 and not 1.42. So for React Native apps, running pod install can only fetch 1.33, unless you manually link to the URL for 1.42 in the Podfile. @megan can your team please look into publishing the latest version to cocoapods?

FYI I was able to confirm the version on cocoapods by searching “Fullstory” on this page:

Userlevel 5

Hey @hans! Thanks so much for your post! 

I see you’ve opened a ticket with our awesome Support team and they let you know our engineers are looking into what's needed in order to get this updated. 

They’ll be able to continue the conversation with you there, but please don't hesitate to reach out should you have any other questions!

Userlevel 5

Hey all! 👋 Jumping in here to share that we’ve pushed out an update yesterday with the latest SDK (1.43.1). You can check out our release notes for more information!

If you have any questions, please let us know! And as always, is available for any technical troubleshooting. 😊